import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\d-)\\d+|\\d+(?=-\\d+)|\\d+(?=(?:\\/\\d+)*b)";
final String string = "Name 789, 10-mill 12-27b\n"
+ "Manufacturer XY-2822, 10-mill, 17-25b\n"
+ "Other Manufacturer 16b Part\n"
+ "Another Manufacturer FER M9000, 11-mill, 11-40\n"
+ "18b Part\n"
+ "Maker 11-31, 10-mill\n"
+ "Maker 1x or 2x; max size 1x (34b), 2x (38/24b)\n"
+ "Maker REC6 15/18/26b. Square.\n"
+ "Producer FC-40 11-13-16-19-22-25-27-30-34b";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}