$re = '/\d+(?=\.(?:[^\d]|$))/';
$str = '4.5.3.
41.53.32.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);