$re = '/[0-9\s-+_\.\(\)\[\]]{5,18}/m';
$str = '345jgfd+_
2343_+4243
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);