re = /(?:[^\\]|^)(".*?[^\\]")/m
str = '" this is a string "
but I can not use that in this:
" this is a \\"string\\" "'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end