import re
regex = re.compile(r"(-(.*)\n\s*\n)*", flags=re.UNICODE | re.MULTILINE)
test_str = ("- Give on result\n"
"- Second new text\n"
"- The third text\n\n"
"Another paragraph without list.\n\n"
"-New list here")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")