package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:-|\/)(foo|bar)(?:\"([^\"]*)\")?(?:$|[[:space:]])`)
var str = `"bla bla -foo" /bar"Text -foo" -foo
-foo""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}