package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)somestring`)
var str = `somestring`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}