#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?\:\/\/(?:[[:alnum:]]+\.)?[[:alnum:]]+\.(?:com|net|org)\/\S*)|(https?\:\/\/(?:\d{1,3}\.){3}\d{1,3}\/?(?:\:\d{0,6})?\/?)"
Local $sString = "Screen 0: minimum 320 x 200, current 3520 x 1080, maximum 8192 x 8192" & @CRLF & _
"VGA-0 connected 1600x900+1920+180 (normal left inverted right x axis y axis) 443mm x 249mm" & @CRLF & _
" 1600x900 60.00*+ 75.00 " & @CRLF & _
" 1280x1024 75.02 70.00 60.02 " & @CRLF & _
" 1440x900 59.89 " & @CRLF & _
" 1280x800 59.81 " & @CRLF & _
" 1152x864 75.00 " & @CRLF & _
" 1280x720 59.97 " & @CRLF & _
" 1024x768 75.08 70.07 60.00 " & @CRLF & _
" 832x624 74.55 " & @CRLF & _
" 800x600 72.19 75.00 60.32 56.25 " & @CRLF & _
" 640x480 75.00 72.81 60.00 " & @CRLF & _
" 720x400 70.08 " & @CRLF & _
"LVDS connected (normal left inverted right x axis y axis)" & @CRLF & _
" 1366x768 59.97 +" & @CRLF & _
" 1280x720 59.86 " & @CRLF & _
" 1152x768 59.78 " & @CRLF & _
" 1024x768 59.92 " & @CRLF & _
" 800x600 59.86 " & @CRLF & _
" 848x480 59.66 " & @CRLF & _
" 720x480 59.71 " & @CRLF & _
" 640x480 59.38 " & @CRLF & _
"HDMI-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 1150mm x 650mm" & @CRLF & _
" 1360x768 60.02 +" & @CRLF & _
" 1920x1080 60.00* 59.94 30.00 24.00 29.97 23.98 " & @CRLF & _
" 1920x1080i 60.00 59.94 " & @CRLF & _
" 1280x1024 60.02 " & @CRLF & _
" 1280x720 60.00 59.94 " & @CRLF & _
" 1024x768 60.00 " & @CRLF & _
" 800x600 60.32 " & @CRLF & _
" 720x480 60.00 59.94 " & @CRLF & _
" 640x480 60.00 59.94 59.94 " & @CRLF & _
" 720x400 70.08 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"https://www.example.com/foo/?bar=baz&inga=42&quux" & @CRLF & _
"http://✪df.ws/123" & @CRLF & _
"http://userid:password@example.com:8080" & @CRLF & _
"http://userid:password@example.com:8080/" & @CRLF & _
"http://userid@example.com" & @CRLF & _
"http://userid@example.com/" & @CRLF & _
"http://userid@example.com:8080" & @CRLF & _
"http://userid@example.com:8080/" & @CRLF & _
"http://userid:password@example.com" & @CRLF & _
"http://userid:password@example.com/" & @CRLF & _
"http://142.42.1.1/" & @CRLF & _
"http://142.42.1.1:8080/" & @CRLF & _
"http://➡.ws/䨹" & @CRLF & _
"http://⌘.ws" & @CRLF & _
"http://⌘.ws/" & @CRLF & _
"http://foo.com/blah_(wikipedia)#cite-1" & @CRLF & _
"http://foo.com/blah_(wikipedia)_blah#cite-1" & @CRLF & _
"http://foo.com/unicode_(✪)_in_parens" & @CRLF & _
"http://foo.com/(something)?after=parens" & @CRLF & _
"http://☺.damowmow.com/" & @CRLF & _
"http://code.google.com/events/#&product=browser" & @CRLF & _
"http://j.mp" & @CRLF & _
"ftp://foo.com/baz" & @CRLF & _
"http://foo.bar/?q=Test%20URL-encoded%20stuff" & @CRLF & _
"http://مثال.إختبار" & @CRLF & _
"http://例子.测试" & @CRLF & _
"http://उदाहरण.परीक्षा" & @CRLF & _
"http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com" & @CRLF & _
"http://1337.net" & @CRLF & _
"http://a.b-c.de" & @CRLF & _
"http://223.255.255.254" & @CRLF & _
"" & @CRLF & _
"SHOULD NOT MATCH:" & @CRLF & _
"" & @CRLF & _
"http://" & @CRLF & _
"http://." & @CRLF & _
"http://.." & @CRLF & _
"http://../" & @CRLF & _
"http://?" & @CRLF & _
"http://??" & @CRLF & _
"http://??/" & @CRLF & _
"http://#" & @CRLF & _
"http://##" & @CRLF & _
"http://##/" & @CRLF & _
"http://foo.bar?q=Spaces should be encoded" & @CRLF & _
"//" & @CRLF & _
"//a" & @CRLF & _
"///a" & @CRLF & _
"///" & @CRLF & _
"http:///a" & @CRLF & _
"foo.com" & @CRLF & _
"rdar://1234" & @CRLF & _
"h://test" & @CRLF & _
"http:// shouldfail.com" & @CRLF & _
":// should fail" & @CRLF & _
"http://foo.bar/foo(bar)baz quux" & @CRLF & _
"ftps://foo.bar/" & @CRLF & _
"http://-error-.invalid/" & @CRLF & _
"http://a.b--c.de/" & @CRLF & _
"http://-a.b.co" & @CRLF & _
"http://a.b-.co" & @CRLF & _
"http://0.0.0.0 " & @CRLF & _
"http://10.1.1.0" & @CRLF & _
"http://10.1.1.255" & @CRLF & _
"http://224.1.1.1" & @CRLF & _
"http://1.1.1.1.1" & @CRLF & _
"http://123.123.123" & @CRLF & _
"http://3628126748" & @CRLF & _
"http://.www.foo.bar/" & @CRLF & _
"http://www.foo.bar./" & @CRLF & _
"http://.www.foo.bar./" & @CRLF & _
"http://10.1.1.1" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")