re = /^(?!.*(.).*\1)(?=M)((?=!7|!D|!a|!§|!¾|!Ö|!ù|!Äš|!į|!Ň|"C|"s|"t|"¡|"°|"»|"è|"ñ|"÷|"Ä·|"ļ|"Å’|#W|#k|#l|#o|#q|#¶|#À|#Â|#Æ|#Ä|%!|%1|%O|%ÿ|%Ä”|%Äž|%Ī|%Ä|&e|&q|&Õ|&æ|&ü|&Ä‘|&Ĩ|'%|'`|'k|'¯|'É|'Ã|'þ|'Ä—|'Äž|'Ä©|'IJ|'ļ|'Å‚|,%|,'|,l|,ª|,®|,¸|,¹|,ã|,õ|,ÄŠ|,Ä |,Ī|,İ|,Å…|-U|-V|-»|-Ã|-Þ|-ì|0_|0u|0°|0Ä |0İ|0Å‚|1#|1-|1g|1Ã¥|1é|1Ä…|1Ä»|1Å„|2B|2O|2¬|2ë|2ò|2õ|2Äž|2Ä©|2į|2IJ|2ļ|3d|3²|3Ã|3Þ|3ß|3ç|3ø|3ĉ|3Ä·|3ĸ|3Ä¿|4c|4£|4ß|4ã|4ÄŠ|4Ä£|4Ĩ|4Å‘|4Å’|5&|5Q|5û|5Ä€|5Ä›|5Ä©|6ú|6Ķ|6Å|7Q|7V|7e|7²|7Ã|7Þ|7à |7Ä‘|7Ä |7ĵ|8w|8¯|8¾|8ņ|8Å‘|9H|9Y|9i|:6|:s|:¬|:ð|:ü|:Ĉ|:ÄŠ|:Ä´|:ĸ|:Ä¿|;X|;®|;¯|;²|;¸|;Ó|;à |;Ä¥|;Å’|<-|<t|<Ã¥|<ø|<Ä®|<Ľ|<Å|=&|=l|=¨|=Ã|=Ã|=ÄŒ|=Ĩ|=Ń|>-|>±|>¸|>Ä|>à |>ð|>ó|>Ī|@B|@F|@_|@³|@´|@Ó|@Ü|@ã|@û|@Äž|@ÄŸ|@Ĭ|@İ|@Ä¿|A5|AV|A_|Ax|A¹|AÃ…|AÄž|AĶ|Aņ|AÅ|B¼|BÂ|Bä|Bç|BÄŠ|Bį|Bİ|BÄ»|BÅ…|C1|C<|CG|Cy|C~|C¼|Cì|Cù|CÅ|DT|DU|Dc|Dj|D¤|DÂ|DÑ|DÄ€|Dİ|E,|E¬|E¼|E×|EÄ|EÄ—|EÅ„|FZ|Ft|F»|F¿|FÈ|FØ|Fç|Fì|Fć|FĬ|Fı|FÅ…|Gj|Gl|Gv|G¯|Gâ|Gï|GÄ–|GÄ™|GĦ|GÄ|H8|HB|HS|Hu|HÂ¥|HÃ|HÃŒ|Hø|HĆ|HÄ’|HĬ|HÄ|I=|It|I©|Iæ|IÄ¿|IÅ|J1|J3|J5|JQ|JÉ|JÔ|J×|Jă|JIJ|K-|KP|KÄ|Kî|KÄ|KÄ|KÄ¡|KĨ|KÄ´|L!|LÃ|Lá|LÄš|LÄ |M5|M¿|MÃ…|MÃ¥|MĈ|MÅŠ|N,|N2|N5|NB|Nh|NÂ|NØ|NÜ|NÄ–|NÄ|NŃ|O;|Of|O¯|O¸|OÃ¥|OĈ|OÄ|OÄ“|OIJ|P7|PQ|Pp|P£|PÄ‘|PÄ´|PÅ€|Q7|QR|QÂ¥|QÃ|Qî|QÄ«|Qĸ|QÅ€|QÅ‘|R0|RA|RI|RN|RÂ¥|R¼|Rö|Rû|RĬ|RÄ®|RÅŽ|S;|SC|ST|Sd|Sy|S§|TX|Td|Tw|Tª|T¿|Tõ|U0|U:|UÊ|Uĉ|UÄ™|UÄ¢|UĦ|Uį|UĶ|Uň|V:|Vq|Vs|V¦|VÂ|Vó|Vþ|Wh|WÃ…|WÉ|Wê|Wô|WÄ£|Wň|X:|XI|XS|X`|Xâ|XÄ‹|XÄ—|XÄ |XÄ£|Y"|YX|Yb|Yn|Yo|Y£|Y§|YÃŒ|YÃŽ|YÚ|Yá|Yă|YÄœ|YÄ¥|YÄ¿|Yʼn|Z6|Z:|Z;|Z¶|ZÃ¥|Zæ|ZÄ‹|Zĺ|ZÅŠ|_,|_-|_c|_g|_à |_ĉ|_Ħ|_Å‚|`I|`z|`ð|`ă|`IJ|`ij|a4|a9|aF|a½|aä|añ|aÄ|aÄ|aĸ|b&|b7|b¸|bÃ|bë|bĺ|bņ|bÅŠ|c&|cP|cr|cÄ|cÑ|cÖ|cÄŒ|cÄ™|cÄ©|cIJ|cÄ·|cÄ¿|d"|dI|dÂ¥|d¦|dä|dÄ£|eK|e²|eý|eÄ…|eÄŒ|eÄ”|eIJ|eĶ|eÅ„|fM|fm|fÂ¥|fÇ|fÃ’|fæ|fì|fć|fÄ›|fÄ|g!|gN|gx|gz|gÃ|gÄš|gÄž|h"|h¬|h¶|hä|hì|hï|hĆ|hņ|hÅ‹|hÅ|i'|i9|i¢|i¤|iÓ|iÖ|iÄ|iÄ•|iÄ|iį|iĶ|jH|jT|j£|jµ|j·|jø|jĸ|jÅ|k0|k2|kA|k~|k¨|k½|kÙ|l&|lX|lc|ln|l£|lÂ¥|lµ|lÃ|lÃ¥|lé|lÄ©|lÅŒ|lÅ’|m-|mW|mÃ|mĘ|mÄ®|mĸ|n!|n2|nJ|nU|n¬|n½|nĆ|nÄ’|nÄ”|nÄ|nŇ|o5|o<|oD|oM|oÖ|oÄ‚|ps|pz|pº|pê|pÄ¢|pÄ¥|pIJ|qK|qa|q§|qÛ|qç|qý|qă|qÄ’|qÄ´|qĶ|qÅ„|rA|re|rj|r§|r«|r¿|rÃ|rß|rò|rÄ”|rÄ–|rÄ¢|rÄ·|sD|sc|sÃ|sÄ€|tT|tW|ta|t£|t¯|t±|tÊ|tÑ|tÄš|tļ|uV|ua|ub|uf|u¦|u´|u»|u¾|uË|uØ|uÄž|uĪ|uĹ|v:|vi|vw|v§|v½|vÄ|vÈ|vÃŒ|vù|vÄ®|vļ|vʼn|vÅŽ|w!|w0|wZ|wg|wÞ|wæ|wò|wù|wÄ¥|wħ|wÅŽ|xD|x©|x®|xá|xû|xÄ£|xľ|xÅ‚|yC|ya|yr|y²|yÉ|yò|yĆ|yÄ |yĵ|yÅ’|zM|zi|z¯|zø|zú|zć|zÄ‘|~5|~Y|~¨|~º|~Û|~Ã¥|~ê|~ô|~ü|~Ä…|~Ä¥|~Ī|~İ|~Ľ|~Å|¡J|¡±|¡¼|¡Ê|¡Ë|¡Ñ|¡ã|¡Ă|Â¡Ä |¡Ĩ|¡ī|¡Œ|¢@|¢G|¢±|¢º|¢ç|¢Ä|¢İ|¢Ŀ|£F|£e|£Þ|£ä|£Ĵ|¤P|¤p|¤¯|¤µ|¤þ|¤Ä|¤Ģ|¤ī|Â¥Z|¥¤|¥È|¥Ñ|¥û|¥Ď|¦T|¦Y|¦Z|¦a|¦b|¦e|¦q|¦r|¦¡|¦³|¦ĩ|¦IJ|¦ĺ|§b|§n|§w|§¿|§Ç|§Ä|¨3|¨Ã|¨Ë|¨Î|¨ë|¨÷|¨Č|¨ġ|¨Ī|¨Ĺ|¨ł|¨Œ|©I|©Z|©Ã|©ë|©ü|©ġ|©ŋ|ªP|ªo|ªr|ª¨|ª¯|ª²|ª¾|ªÇ|ªÔ|ªÙ|ªĉ|«K|«p|«£|Ǭ|«©|«¬|«®|«Õ|«Þ|«ß|«ö|«Ä|¬!|¬j|»|¬¼|¬À|¬Ã|¬Ì|¬ú|¬ő|®#|®´|®É|®Ä|®đ|®ī|®ʼn|¯9|¯g|¯n|¯¹|¯È|¯Ē|¯ę|¯ġ|°N|°d|°k|°m|°s|°²|°È|°Î|°ê|°ó|°ʼn|±%|±R|±Y|±r|±æ|±Ŀ|±ń|²D|²H|²U|²×|²ã|²ä|²ç|²ą|²ħ|³`|³Ë|³ã|³ë|³ò|³ô|³ø|³Ċ|³Ĥ|³Ŀ|´~|´§|´Ê|´è|´Ķ|´Ŏ|µ:|µC|µ¢|µØ|µó|嵀 |µģ|µĤ|¶!|¶0|¶7|¶Y|¶¤|¶À|¶Ö|¶Ħ|¶ő|·p|·Ã|·Ç|·ë|·î|·Ļ|·Ŋ|¸X|¸Z|¸¦|¸÷|¸ú|¸Ä|¸Ä|¹,|¹>|¹M|¹Z|¹a|¹¢|¹Ì|¹×|¹Ø|¹þ|¹ĉ|¹Ĩ|º>|ºj|ºá|ºç|ºý|ºć|»2|»c|»°|Ȁ|Ȗ|Â»Ä |»Ŋ|¼3|¼F|¼c|¼d|¼x|¼y|¼Ä|¼É|¼û|¼Č|¼ē|¼Ĩ|¼Ĭ|¼Ĵ|¼Ĺ|½k|½Ø|½ø|½ħ|¾2|¾:|¾L|¾¿|¾Ã|¾ñ|¾ô|¾÷|¾đ|¾ĥ|¾Ń|¿D|¿«|¿ö|¿ø|¿Ĕ|¿ę|¿Ļ|¿Å|À3|ÀW|ˡ|ÀÆ|Àđ|ÀĘ|ÀĞ|Àģ|Àİ|ç|Ãé|Ãõ|ÃÄœ|ÃÄ|ÃĪ|Ãʼn|Â&|ÂB|ÂM|¿|Âø|Âħ|Âĺ|ÂĻ|ÂÅ|Âʼn|Ã`|Ãt|â|é|ÃĆ|ÃĖ|Ãĥ|Ãĩ|Ä_|Ä¥|ÄÌ|ÄÞ|Äð|ÄĆ|Äİ|ÄÅ|Ã…@|Ã…Y|Å«|Ã…Ä„|Åı|Åĸ|Æ;|ÆK|Æv|Ƶ|ƹ|ƽ|ÆÇ|ÆÛ|Æõ|Æü|ÆĆ|ÆĤ|Çd|Ǻ|ÇĔ|Çě|Çģ|ÇĶ|ÇĽ|Èd|Èz|È~|È´|Ƚ|ÈÂ|Èæ|Èõ|ÈŅ|ÉH|ÉO|ÉÌ|Éï|ÉČ|Éę|ÉĬ|ÉÄ|ÉĴ|ÉŎ|Ê%|Ê6|ÊI|Êk|Êy|ʳ|ÊÃ|Êñ|Êą|ÊŃ|Ë!|ËH|Ëh|˺|Ë»|ËÆ|Ëğ|ËŌ|ÃŒ3|ÃŒ7|ÃŒG|ÃŒp|Ì«|Ìè|Ìï|ÌĮ|ÌŎ|ÃZ|Ãd|é|ÃÖ|Ãá|Ãê|Ãø|ÃÄ|ÃÅŠ|ÃŽ-|ÃŽ_|ÎÊ|Îæ|Îó|Îù|ÃŽÄ€|ÃŽÄ|ÃŽÄ¡|ÃŽÄ|ÎŇ|Ã"|Ã5|Ã7|ÃA|ÃH|Ãl|ñ|ù|ÃÈ|ÃØ|ÃÚ|ÃÛ|ÃÄ»|Ãʼn|ÃR|÷|ÃÀ|ÃÓ|ÃÄ’|ÃÄ›|ÃĶ|Ãľ|Ñ©|ѵ|ÑÅ|ÑÈ|Ñʼn|Ã’V|ÒÇ|Òĉ|Òħ|ÒŃ|Ó2|ÓD|ÓÎ|Óç|Ó÷|Óù|ÓĈ|Óķ|ÔE|ÔJ|Ôf|Ôy|ÔÆ|ÔÞ|Ôâ|ÔĂ|ÔĨ|Õ3|ÕG|Õh|Õ¹|ÕÃ|ÕÃ|Õÿ|Õğ|Õī|Ö7|ÖB|Öª|Ö¼|Öÿ|Öħ|Öij|×6|×>|×f|×¢|×µ|×·|×Â|×Ê|×Ñ|×ã|ØG|د|ØÄ|ØÊ|Øé|Øë|ØĊ|ØŇ|ØÅ|Øő|Ù:|Ùh|Ùx|Ù²|ÙÄ|Ùē|Ùę|Ùě|ÙĨ|ÙŇ|ÚE|Úq|Ú®|ÚÄ|ÚÒ|ÚÜ|Úä|ÚÃ|Úı|Úķ|Û'|ÛW|Ûo|Ût|ÛÓ|Ûô|Ûõ|Ûû|Ûʼn|Ûŋ|Ü!|ÜJ|ÜÆ|ÜÅ|ÃR|Ãg|Ãq|Ãu|ÃÜ|Ãß|Ãð|Ãø|ÃÄ|ÃĶ|Ãʼn|Þº|ÞÃ|ÞĂ|Þą|Þć|ÃžÄ |ÞĨ|ßu|ßÀ|ßė|à 4|à S|à `|à k|à §|à é|à ø|à Ċ|à ę|à ģ|à Ĭ|á3|á£|á¶|áÄ|áÃ|áÑ|áâ|áü|áČ|áĽ|áņ|áŌ|â#|âY|â£|âº|âÓ|âġ|âÄ|âı|âÅ|âŒ|ã,|ã1|ã7|ã8|ãé|ãÄ|ä3|ä6|äN|ä¢|ä©|ä¬|äÃ|äĖ|äį|äÅ|Ã¥N|å¡|å¾|åØ|åë|åû|Ã¥Ä|åě|æ7|æT|æt|æ¸|æá|æï|æÄ|æij|ç2|çA|çJ|çl|ç¥|ç¬|çÄ|çĸ|èl|èq|èÓ|èÙ|èČ|èĖ|èĩ|èņ|èʼn|èő|éV|éZ|é®|é´|éÃ|éó|éû|éą|éě|éÄ|éŃ|ê5|êv|ê«|ê¶|êº|êÃ|êÔ|êİ|ëB|ëb|ë¤|ë¨|ëÎ|ëę|ëĞ|ì#|ì,|ì=|ì>|ìQ|ìS|ìV|ìº|ìÄ|ìġ|ÃJ|ÃV|Ã~|ö|Ãò|Ãø|Ãă|ÃÄ—|ÃÄ|î<|î=|îD|îR|îµ|îÚ|îÛ|îå|îê|îþ|îĒ|îĜ|îğ|ï%|ï,|ïa|ïu|ïÀ|ïÃ|ïá|ïĄ|ïą|ïċ|ïġ|ïĿ|ïÅ|ïŌ|ð6|ðE|ðp|ð¬|ðÞ|ðä|ðĚ|ðğ|ðļ|ñ1|ñ2|ñX|ñi|ñá|ñú|ñû|ñü|ñį|ñŊ|òB|ò«|ò¿|òÃ|òê|òÄ|ó5|óÄ|óÇ|óÈ|óÓ|óÕ|óĨ|óļ|ô4|ôh|ôÖ|ôî|ôþ|ôğ|ôŅ|õo|õ¢|õ¶|õÆ|õÓ|õä|õČ|õĕ|õģ|ö7|ö@|ön|ö¢|öÉ|öÒ|öÛ|öâ|öÄ|÷-|÷J|÷p|÷Ò|÷Ģ|÷Ä|÷ı|÷ʼn|ø,|øo|ø¥|øÆ|øç|øè|øù|øĤ|øĥ|øħ|øň|ù7|ù9|ùs|ùu|ù¹|ùÃ|ùĆ|ùę|ùě|ùĹ|úG|úÅ|úÕ|úÖ|úÜ|úã|úç|úĂ|úĦ|û%|û;|ûR|ûh|ûu|ûz|û´|ûÃ|ûë|ûń|ûŊ|ü_|ü²|üê|üē|üğ|üł|üŅ|ý8|ý¨|ý©|ýÃ|ýÜ|ýĄ|ýċ|ýĩ|ýı|ýIJ|ýĸ|ýł|ýň|ýŎ|þ;|þD|þJ|þT|þr|þ·|þè|þĆ|ÿO|ÿÒ|ÿæ|ÿð|ÿć|ÿğ|ÿŇ|Ä€A|Ä€R|Ä€_|Ä€v|Āá|ĀĘ|Āģ|Āİ|Ä6|ÄM|ĸ|Ää|ÄÄ®|Ä‚X|Ä‚Ã|ĂÕ|ĂĚ|Ăķ|ĂĹ|ă"|ă°|ă¸|ăÉ|ăĆ|ăĚ|ăğ|ăĸ|ăĻ|ăŃ|Ä„G|Ä„J|Ä„K|Ä„`|Ä„c|Ä„d|Ä„g|Ä„l|Ą³|ĄÄ|ĄÊ|ĄÌ|Ąú|ĄĽ|Ä…;|Ä…L|Ä…c|Ä…d|Ä…o|Ä…r|ą®|ą±|ąÄ|Ä…Ã…|ąÇ|Ä…Ã|ą×|ąĈ|Ä…ÄŽ|Ä…Ä|Ä…Ä©|Ä…ÅŒ|Ć´|Ƹ|ü|ĆÑ|ĆØ|ĆÃ|ĆĊ|Ćņ|ĆŌ|ć4|ćx|ćy|ć¦|ć«|ćù|ćŃ|Ĉ&|Ĉ8|ĈE|ĈK|Ĉn|Ĉ¨|Ĉà |Ĉé|Ĉû|Ĉđ|Ĉĥ|ĈĪ|Ĉī|Ĉņ|ĉ@|ĉa|ĉÇ|ĉ×|ĉĩ|ĉň|ÄŠ#|ÄŠb|ÄŠt|Ċ»|ÄŠÃ|ĊÚ|Ċä|Ċÿ|ÄŠÄ|ÄŠÄ©|Ċį|Ä‹'|Ä‹D|ċ¶|ċÖ|ċê|ċþ|ċğ|ċņ|ÄŒM|ÄŒs|Č£|ČĨ|Čį|ı|ÄÖ|Äè|Äć|ÄÄŸ|ÄÅ„|Äʼn|ÄŽ`|Ď¡|Ď·|Ď¾|Ď¿|ÄŽÄ…|Ďij|ÄŽÅ‹|Ä"|Ä5|Ä8|Ä=|ÄD|Äs|ÄØ|ÄÚ|ÄÃ|ÄÄ¡|ÄÄ©|Äļ|ÄF|ÄS|Äg|Äk|Än|Äv|Ä~|ÄÖ|ÄÚ|ÄÜ|Äâ|ÄÄž|Ä‘A|Ä‘f|đ´|đ¸|đ¿|đÈ|đÖ|đà |đĽ|đŀ|đŌ|Ä’%|Ä’H|Ä’Ã|ĒĹ|Ä’Ä»|Ä’Å|ĒŃ|ĒŇ|Ä“;|Ä“G|Ä“a|Ä“e|Ä“q|ē¶|ē»|ē÷|ēň|Ä”"|Ä”4|ĔÃ|Ĕý|Ĕą|ĔĆ|ĔĚ|ĔĞ|ĔĨ|Ä•"|Ä•m|Ä•w|ĕ¨|ĕ®|ĕÌ|ĕÑ|ĕĤ|Ä–#|Ä–R|Ä–e|Ä–u|Ä–~|˝|Ä–Ä©|ĖĬ|Ä—H|ė¹|ėö|ėú|ėÿ|ėĨ|Ęs|ĘÃ|Ęą|ĘČ|ĘÄ|Ęī|Ęĺ|Ęʼn|Ä™A|Ä™k|Ä™p|ę»|ęè|ęą|Ä™Ä|ęĨ|Äš'|Äš9|Äše|Äšm|Äšo|Ě£|Ěª|Ě¾|Ěå|Ěë|Ěă|ĚĎ|ĚĜ|ĚĞ|Ä›P|Ä›x|ěê|ěî|ěö|ěĂ|ěĤ|Ä›Ä|ěļ|Äœ%|ĜÜ|ĜĽ|ÄJ|Äh|Ĺ|ÄÃ|ÄÈ|ÄÄ–|ÄÄž|ÄŇ|ÄÅ’|Äž&|Äže|Äžs|ĞÖ|ÄŸX|ğ²|ğ´|ğ¼|ğÙ|ğò|ÄŸÄ‚|ÄŸÄ‘|ÄŸÄ•|ğĨ|ğĬ|Ä B|Ä c|Ä Âµ|Ä Ãˆ|Ä Ã¨|Ä Ã¬|Ä Ä‘|Ä Ä›|Ä¡5|Ä¡<|Ä¡H|Ä¡m|ġº|ġÒ|ġü|ġă|ġĶ|ġŀ|Ä¢;|̤|Ģ«|Ä¢Ã|ĢØ|Ģù|Ģă|Ä¢Ä|Ģđ|Ä£-|Ä£L|ģ«|ģë|ģþ|ģċ|ģČ|ģĨ|ģĻ|Ĥf|Ĥª|Ĥñ|Ä¥M|Ä¥N|Ä¥U|Ä¥f|Ä¥z|ĥ»|ĥõ|ĥň|Ħ`|Ħj|Ħu|Ħ°|Ħ´|ĦÃ|ĦÈ|ĦÕ|Ħæ|ĦĤ|ħ4|ħp|ħ¡|ħ¦|ħ¶|ħß|ħç|ħĴ|ħĵ|ĨC|Ĩ°|ĨÂ|ĨÌ|Ĩç|Ĩõ|ĨĔ|ĨÅ|Ä©8|Ä©l|Ä©t|Ä©w|ĩċ|ĩđ|ĩĥ|ĩī|ĩŅ|Ī4|Ī9|ĪP|Īz|α|ĪÅ|ĪÈ|ĪÃ|Īä|Īđ|ĪĦ|ĪĬ|ĪĽ|Ä«b|Ä«l|ī¥|ī¦|īÌ|īì|īČ|īĎ|Ä«Ä|Ĭ#|Ĭ4|ĬF|Ĭ¤|Ĭê|ĬÃ|Ĭû|ĬÄ|ĬŌ|Ä1|ÄK|ÄL|Äz|Ä¡|į|ÄÃŒ|Äâ|ÄĘ|ÄÄ›|Äĺ|Ä®M|Ä®R|Ä®d|Ä®x|Į¤|ĮÃ|ĮË|ĮÚ|Įå|ĮĤ|ĮĦ|Įī|į&|įD|įI|į¥|į«|įÉ|įÕ|įÛ|įĉ|įđ|įĒ|İQ|İi|ݬ|ݾ|İÕ|İ×|İĄ|İĬ|İľ|ı4|ıa|ıd|ıe|ıf|ı¡|ıÄ|ıĖ|ıIJ|IJ:|IJT|IJU|IJm|IJÛ|IJķ|IJŎ|ij0|ijb|ij¢|ij«|ijé|ijÃ|ijĎ|ijĘ|ijķ|Ä´#|Ä´F|Ä´G|Ĵµ|Ĵ¹|ĴÈ|Ä´Ã|Ĵý|Ĵþ|Ä´Ä–|ĵ8|ĵE|ĵK|ĵ¦|ĵ±|ĵÙ|ĵó|ĵõ|ĵĹ|Ķ6|ĶE|Ķl|Ķm|Ķ£|Ͳ|ĶÅ|Ķ÷|ĶĀ|Ķă|ĶĆ|Ä·v|ķ«|Ä·Ã¥|Ä·Ä¢|Ä·ÅŒ|ĸ9|ĸH|ĸ¼|ĸè|ĸý|ĸĕ|ĸį|ŧ|Ĺ·|ĹÇ|ĹÈ|Ĺġ|Ĺĩ|ĺ#|ĺ6|ĺp|ĺr|ĺu|ĺæ|ĺÃ|ĺĖ|Ä»@|Ä»I|Ä»n|Ļ£|϶|ĻÂ|Ļú|ĻĮ|ĻŎ|ļ=|ļK|ļO|ļ_|ļ´|ļÀ|ļÄ|ļó|Ľ>|ĽC|ĽD|ĽG|ĽZ|Ľk|Ľr|Ľ¼|ĽÌ|Ľâ|ĽĮ|ĽŒ|ľf|ľÙ|ľÞ|ľĂ|ľī|ľł|ľņ|ĿÊ|Ä¿Ä|Ŀđ|ĿĚ|Ŀĵ|ĿĻ|Ä¿Å|Å€C|Å€M|ŀ®|ŀà |ŀð|ŀõ|ŀČ|ÅE|ÅÃ|ÅÄ|Åõ|ÅÄ·|ÅÄ¿|Å‚4|Å‚G|Å‚u|ł¬|Å‚Ã|łò|łČ|Å‚Ä|Å‚Ä|łŌ|Ń6|Ń¿|ŃÅ|ŃË|ŃÚ|Ńü|Ńě|Ńņ|Å„4|Å„<|Å„E|Å„x|ń»|ńÄ|Å„Ä|ńĺ|Å…,|Å…P|Å…e|Å…n|Å…o|Ņ©|ҝ|ҽ|ŅÛ|Å…Ä‚|ņî|ņð|ņô|ņĈ|ņī|ņĬ|ņı|Ň8|Ň:|ŇD|ŇT|Ň_|Ňd|Ňu|Ňª|ŇÄ|Ňć|ŇĈ|Ňň|ňK|ňL|ň¬|ňÇ|ňÃ|ňþ|ňÄ|ÅˆÄ |ňÅ|ʼnQ|ʼn_|ʼnf|ʼnÉ|ʼnË|ʼnĨ|ʼnŃ|ÅŠ0|ÅŠM|ÅŠW|ŊÔ|ÅŠÄ |Å‹C|Å‹H|Å‹K|Å‹Ã|ŋÒ|ŋØ|ŋÞ|ŋı|ŋĹ|ÅŒ,|ÅŒl|Ō³|Ōò|ÅŒÄ|ŌĖ|ŌĚ|ŌĬ|ŌĮ|Ōĸ|ŌŒ|ÅJ|Å¿|ÅÀ|ÅÃ|Åʼn|ÅŽ8|ÅŽ;|ÅŽQ|ÅŽV|Ŏ§|ŎÄ|ÅŽÃ|ÅŽÄŽ|ŎŇ|Å=|ÅD|ÅV|Ź|ÅÈ|ÅÃ’|ÅÄ|ÅÄ|ÅÄ«|ÅÄ¿|Åʼn|Å2|Å<|ÅC|ÅX|Åg|Ål|Åp|Å®|Åİ|Å‘8|ő¹|őÀ|őó|őć|őĊ|őĖ|őĦ|őķ|őĸ|őŀ|Å’B|Å’v|ŒÀ|Å’Ã’|Å’Ä|Œĉ|Å’Ä—|Å’Äœ|ŒĦ|Å’Ä·|Œľ).){255}Ň$/
str = 'MŊÔEÅ„ÄĩĥN2BÅ…n!7²çÄÄ–ua9iĕ®īìºj·îRĮÚäÃÈæïąŌ,Ä Ã¨lŒĜÜÅ<-»°Îùęk½ħĵÙÄʼnËÆµØő¹Zå¾ôÖª¨ġÒĉ@Ftļ=ÄŒsĀĘÃqÛû%ĔýIJU:ü_ł¬Ã¢±ĿĻÂĺr§b¸¦eĶăĚmWhÅVþ;XSdI©ë¤pzúã8w0İ×>à éóÓķĢÄâY"÷ı¡Ê³øĤñá¶Ħ´~Ī4cÑÅĄĽÌ«ßėÿOēňLÃľfćxDT¿öÉÄÄ›P£ĴG¯ĒŃņĈKĨCyĆĊįÕÃõo5Qŀðğ¼3ĸHĬ#ÀĞ&Ä‘AÅJ1gÃÄ6ÅÄ¥ĎŋÞĂĹÇģċ\'`ijÃòêvŎŇ'
# Print the match result
str.match(re) do |match|
puts match.to_s
end