$re = '/\s[0-1]{1}[0-9]{0,2}/';
$str = ' 199
12
0
200
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);