$re = '/\[A][\s\S]*?(?=\[A]|$)/m';
$str = '[A]I\'m an example text [] But I want to be included [[]]
[A]I\'m another text without a second part []';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);