$re = '/(.*?(\d+))/m';
$str = 'Jan 1987
May 1969
Aug 2011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);