$re = '/([a-zA-Z]+( [a-zA-Z]+)*)(?=;\w+$)/m';
$str = '220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad
221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore
222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai
222;Emma;23/11/2008;22/12/200825;Enginner;Chennai
222;Emma;23/11/2008;22/12/200825;5th Enginner;Chennai';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);