import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\[.*?(?P<parts>\\d{1,3}\\/\\d{1,3}) ] - \"(?!.*\\sS\\d{1,2}(?:E\\d{1,3})?\\s)(?P<name>.*?)\\.(vol|rar|par|sfv|nfo|nzb)";
final String string = "I want the regex to match results like\n\n"
+ "[ TrollHD ] - [ 002/124 ] - \"2015 Dream Concert 1080p Netflix WEBRip DD+ 2.0 x264-TrollHD.part001.rar\" yEnc (1/164)\n\n"
+ "but skip results like\n\n"
+ "[ TrollHD ] - [ 04/30 ] - \"Chelsea S02E05 1080p Netflix WEBRip DD+ 2.0 x264-TrollHD.part03.rar\" yEnc (1/164)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}