re = /^(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:\.(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3}$/
str = '127.000.000.255'
# Print the match result
str.match(re) do |match|
puts match.to_s
end