using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s|^)\+(\w+)";
string input = @"+aaa sww++bbb sww+bbb ++ccc ddd eee+ fff++ +ggg hhh";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}