import re
regex = re.compile(r"^(((1)st?|(2)nd?|(3)rd?|([4-9])th?)|(([0-9]*)(1[0-9])th?)|(([0-9]*[02-9])((1)st?|(2)nd?|(3)rd?|([04-9])th?)))$", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("// ordinals\n"
"1st\n"
"22nd\n"
"333rd\n"
"4444th\n"
"2500th\n\n"
"// teens\n"
"11th\n"
"12th\n"
"13th\n"
"14th\n"
"15th\n"
"16th\n"
"17th\n"
"18th\n"
"19th\n\n"
"// teens - hundreds\n"
"111th\n"
"112th\n"
"113th\n"
"114th\n"
"115th\n"
"116th\n"
"117th\n"
"118th\n"
"119th\n\n"
"// teens - wrong suffix\n"
"11st\n"
"12nd\n"
"13rd\n"
"111st\n"
"112nd\n"
"113rd\n\n"
"// uppercase\n"
"1ST\n"
"22ND\n"
"333RD\n"
"444TH\n\n"
"// wrong suffix (do nothing)\n"
"0th\n"
"26st\n"
"31th\n"
"21rd\n"
"29nd")
subst = "$3$4$5$6$8$9$11$13$14$15$16"
result = regex.sub(subst, test_str)
if result:
print(result)