re = /^(?=.*[a-z])(?=.*[A-Z)(?=.*[0-9~!@#$%^&*])[a-zA-Z0-9~!@#$%^&*]{6,32}$/m
str = 'amanDeee
Amandeep'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end