$re = '/^\d+(?:,\d+)+$/m';
$str = '123,456
634,34643,3424
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);