re = /[^,]+?W\b/m
str = 'text = "Fast charging 25W, USB Power Delivery 3.0, Fast Qi/PMA wireless charging 12W, Reverse wireless charging 4.5W"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end