re = /^Linus::(?:.*::CASE$|.*?(?=::|$))/m
str = 'Linus::AOPKNS::CASE
Linus::AOPKNS
Linus::AOPKNS::OK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end