$re = '/[A-Z]{3}[0-9]{6}[A-Z0-9]{3}/';
$str = 'ZAC810304NM0';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);