$re = '/\w+\/[^\/]+?(?= \w+\/|$)/';
$str = 'DEP/S10 DEST/3W5 ALTN/1S2 RMK/TESTING, PLEASE IGNORE TYP/HOMEBUIL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);