#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[0-9]+$"
Local $sString = "0" & @CRLF & _
"1" & @CRLF & _
"-0" & @CRLF & _
"-1" & @CRLF & _
"+0" & @CRLF & _
"+1" & @CRLF & _
"01" & @CRLF & _
"-01" & @CRLF & _
"+01" & @CRLF & _
"" & @CRLF & _
"2.3" & @CRLF & _
"-2.3" & @CRLF & _
"1.00" & @CRLF & _
"0.00" & @CRLF & _
"-0.00" & @CRLF & _
"00.00" & @CRLF & _
"-00.00" & @CRLF & _
"02.3" & @CRLF & _
".0" & @CRLF & _
".1" & @CRLF & _
"-.1" & @CRLF & _
"0." & @CRLF & _
"1." & @CRLF & _
"10." & @CRLF & _
"2,3" & @CRLF & _
",0" & @CRLF & _
"" & @CRLF & _
"0e0" & @CRLF & _
"2e5" & @CRLF & _
"-e10" & @CRLF & _
"-e-10" & @CRLF & _
"2.3e5" & @CRLF & _
"-2.3e5" & @CRLF & _
"2.3e-5" & @CRLF & _
"2.3e03" & @CRLF & _
"2.3e0" & @CRLF & _
"0.01e4" & @CRLF & _
".1e5" & @CRLF & _
"-.1e5" & @CRLF & _
"-.0e0" & @CRLF & _
"-0.0e10" & @CRLF & _
"2,3e5" & @CRLF & _
" " & @CRLF & _
"." & @CRLF & _
"-" & @CRLF & _
"-." & @CRLF & _
"b1" & @CRLF & _
"1b" & @CRLF & _
"2-3" & @CRLF & _
"3.4.5" & @CRLF & _
"4.,6" & @CRLF & _
"1,." & @CRLF & _
"e" & @CRLF & _
"-e" & @CRLF & _
"-.e" & @CRLF & _
".e4" & @CRLF & _
"1e2-2" & @CRLF & _
"e2.3" & @CRLF & _
"e2.3.4" & @CRLF & _
"-e10" & @CRLF & _
"1e.-" & @CRLF & _
"10e." & @CRLF & _
"1\n" & @CRLF & _
"1\t" & @CRLF & _
"1 1" & @CRLF & _
"\n" & @CRLF & _
"\t" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")