$re = '/^[^_]+/m';
$str = 'org.apache.commons.httpclient_3.1.0.v20170718_1537
org.apache.commons.httpclient_3.1.0.v20170718-1537
org.apache.james.mime4j_0.6.0.v20120423
org.apache.james.mime4j_3.1.0.1.v20170718_1537
org.apache.commons.httpclient_3.1.v20170718-1537';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;