$re = '/ ([A-Za-z]{2} ){7}(_[ 0-9]_[0-9])/m';
$str = '"September 2018 Su Mo Tu We Th Fr Sa _ _1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30"
"September 2018: ★ 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30"
';
$subst = ": ★";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;