$re = '/^[0-9,]*$/';
$str = '1245,7999999';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);