$re = '/(?:(\$number_) (cộng|trừ|nhân|chia) )+(\$number_) (bằng) (\$number_)/m';
$str = '$number_ cộng $number_ cộng $number_ cộng $number_ cộng $number_ bằng $number_';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);