using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/\*(.|\n)*?\*\/";
string input = @"int main(/* text */) {
int i = 0;
/* hello world */
return 1;
} ";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}