package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(,\d{1,2})`)
var str = `einmalig gesamt44,00 €
einmalig gesamt28,00 €`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}