package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+\s*[\d-]+)`)
var str = `X 1111-11-112222-22-22YY 3333-33-334444-44-44ZZZ5555-55-556666-66-66AAA7777-77-778888-88-88B 9999-99-991111-11-11"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}