$re = '/^\s*(.*?)\s*(<=|==|>=|[GL]?EQ)\s*(.*?)\s*(!required|!strong|!medium|!weak)?$/m';
$str = 'thumb.top == group.top + 20
group.intrinsicHeight == preamble.bottom !medium';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);