use strict;
my $str = 'local://[A:A:A:A:A:A::AFCE]//kill/0';
my $regex = qr/[a-z](?:[a-z]|\d|[+-.])*:(?:\/\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|:)*@)?(?:\[(?:(?:[0-9a-f]{1,4}:){6}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|::(?:[0-9a-f]{1,4}:){5}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){4}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:)?[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){3}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,2}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){2}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,3}[0-9a-f]{1,4})?::[0-9a-f]{1,4}:(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,4}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,5}[0-9a-f]{1,4})?::[0-9a-f]{1,4}|(?:(?:[0-9a-f]{1,4}:){0,6}[0-9a-f]{1,4})?::|v(?:[0-9a-f])+\.(?:[a-z]|\d|[-._~]|[!$&'()*+,;=]|:)+)]|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=])*)(?::(?:\d)*)?(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*)?|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|)(?:\?(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?(?:#(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}