use strict;
my $str = '[
{
path: \'/my-profile\', name: \'my_profile\', component: MyProfile,
child-ren: [
{
path: \'info\', name: \'my_info\', component: BasicInForm,
},
{
path: \'photos\', name: \'my_photos\', component: MyPhot\'os,
},
{
path: \'questions\', name: \'my_questions\', component: MyQuestions,
},
],
},
{
path: \'/\', name: \'register\', component: RegisterFormFlow,
},
]';
my $regex = qr/([\s\[\{,:]+)(?!\-?\.?\d|false\W|true\W)([^'\":,\s\]\}]+)([:\s,\}\]_\-\{\[]|$)/p;
my $subst = '\\1\'\\2\'\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";