const regex = /^id(\d+), .*$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^id(\\d+), .*$', 'mg')
const str = `id50, 4124fdgfgdfg
id43, 4124fdgfsds
isd43, 4124fdgfsds
43, 4124fdgfsds
i43, 4124fdgfsds
id40, 4124fdgfsds
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}