import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([a-zA-Z0-9\\|\\!\\._\\-\\s\\:]*<a href=\\\"#\\\" onclick=\\\"ON_CLICK_EVENT\\\">[a-zA-Z0-9\\|\\!\\._\\-]*<\\/a>)|(<a href=\\\"#\\\" on(c|C)lick=\\\"(HSBC_pre_chat_est\\(\\)\\;\\s)*ON_CLICK_EVENT\\\"(\\s)*>(\\s)*<img src=(\\'|\\\")[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*(\\'|\\\")(\\s)*(\\/)*>(\\s)*<\\/a>)|(<a href=\\\"#\\\" onclick='try \\{ LPButtonClicked\\(\\)\\; \\} catch \\(e\\) \\{\\}\\; ON_CLICK_EVENT'\\; title=\\\"Start Live Chat\\\"><img src=\\\"[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*\\\" border=0 alt=\\\"Live Chat\\\" onload=\\\"LPButtonDisplayed\\(\\)\\\"><\\/a>)|([a-zA-Z0-9\\|\\!\\._\\-\\s]*<a href=\\\"#\\\" onclick=(\\'|\\\")ON_CLICK_EVENT(\\'|\\\")><span><span class=\\\"lpStartChat\\\">[a-zA-Z0-9\\|\\!\\._\\-\\s]*<\\/span><\\/span><\\/a>)|(<a href='javascript\\:\\;' on(c|C)lick='javascript\\:ON_CLICK_EVENT\\;'>(\\s)*<img src='[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*'(\\s)*(border='0'\\salt='Chat with an HSBC Representative' title='Chat with an HSBC Representative')*(\\/)*>(\\s)*<\\/a>)|(<a href='#' onClick='javascript\\:ON_CLICK_EVENT\\; '>[a-zA-Z0-9\\|\\!\\._\\-\\s]*<\\/a>)|(<h4>Live Chat<\\/h4>(\\s)*<div class=\\\"supportContentGeneralBoxInnerChat\\\">(\\s)*<h5>Welcome to Live Chat<\\/h5>(\\s)*<p>How can we help you\\?<\\/p>(\\s)*<p><a class=\\\"redBtn liveChatBtn\\\" href=\\\"#\\\"(\\s)*onclick=\\\"ON_CLICK_EVENT\\\" title=\\\"Start Chat\\\"><span>Start Chat<\\/span><\\/a><\\/p>(\\s)*<\\/div>)|(<div style='padding\\:0px' box-shadow\\: -3px 3px 10px(\\s)*#888888\\;><a href=\\\"#\\\" onClick='ON_CLICK_EVENT\\;'target=\\\"_self\\\">(\\s)*<img src='[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*'(\\s)*id='SwitchButton' Border='0'\\/><\\/a><\\/div>)|(<div id=\\\"lpButtonTab\\\" style=\\\"float:left; width:30px\\\" onclick=\\\"lpStickyButton\\.toggleState\\(\\);\\\"><img src=\\\"[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*\\\" width=\\\"30\\\" height=\\\"125\\\" border=\\\"0\\\" \\/><\\/div>(\\s)*<div id=\\\"lpButtonArea\\\" style=\\\"margin-left:30px; width:251px\\\"><img src='[a-zA-Z0-9\\|\\!\\._\\-\\:\\,\\/\\s]*' style='cursor:pointer' onclick='ON_CLICK_EVENT' \\/><\\/div>)|(<div class=\\\"liveChatSideBox\\\">(\\s)*<h2>Live chat<\\/h2>(\\s)*<p>Welcome to Live Chat\\. How can we help you\\?<\\/p>(\\s)*<p><a class=\\\"redBtn liveChatBtn\\\" href=\\\"#\\\"(\\s)*onclick=\\\"ON_CLICK_EVENT\\\"(\\s)*title=\\\"Start Chat\\\"><span>Start Chat<\\/span><\\/a><\\/p>(\\s)*<\\/div>))$";
final String string = "<div class=\"liveChatSideBox\">\n"
+ " <h2>Live chat</h2>\n"
+ " <p>Welcome to Live Chat. How can we help you?</p>\n"
+ " <p><a class=\"redBtn liveChatBtn\" href=\"#\" onclick=\"ON_CLICK_EVENT\"\n"
+ "title=\"Start Chat\"><span>Start Chat</span></a></p> </div>\n\n"
+ "<a href=\"#\" onclick=\"ON_CLICK_EVENT\" >\n"
+ "<img src='https://www.hsbc.co.uk/content_static/en/images/en/alt_design_3E.png' />\n"
+ "</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}