using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\t]*";
string input = @"__consumer_offsets 50 3 compact 11.5 kB
_schemas 1 3 compact 576 B
euler.public.apartment 1 3 delete 2.53 GB
euler.public.apartment_accounts 1 3 delete 159 MB
euler.public.apartment_bind_qr_codes 1 3 delete 4.73 MB
euler.public.apartment_cameras 1 3 delete 65.7 MB
euler.public.apartment_favorites 1 3 delete 2.97 MB
euler.public.apartment_plans 1 3 delete 114 kB
euler.public.apartment_property 1 3 delete 2.28 MB
euler.public.apartment_scope_access_rel 1 3 delete 17.7 kB
euler.public.app_schema 1 3 delete 1.67 MB
euler.public.board_map_buildings_tags 1 3 delete 961 kB
euler.public.building 1 3 delete 18.7 MB
euler.public.building_cameras 1 3 delete 940 kB
euler.public.building_coordinates 1 3 delete 729 kB
euler.public.building_enterprise 1 3 delete 407 kB
euler.public.building_images 1 3 delete 136 kB
euler.public.business_center 1 3 delete 6.04 kB
euler.public.cctv_cameras_apartments 1 3 delete 422 MB
euler.public.cctv_cameras_buildings 1 3 delete 7.57 MB
euler.public.cctv_cameras_complex 1 3 delete 2.58 kB
euler.public.cctv_cameras_entrances 1 3 delete 3.65 MB
euler.public.cctv_cameras_properties 1 3 delete 2.56 MB
euler.public.comparison_of_meters_readings_buildings_rel 1 3 delete 110 kB
euler.public.comparison_of_meters_readings_registry 1 3 delete 1.3 MB
euler.public.complex 1 3 delete 2.16 MB
euler.public.complexes_mortgage 1 3 delete 1.37 kB
euler.public.construction_stage_configuration 1 3 delete 7.84 kB
euler.public.debtors 1 3 delete 4.07 kB
euler.public.device 1 3 delete 5.66 GB
euler.public.enterprises_buildings 1 3 delete 1.66 MB
euler.public.entrance 1 3 delete 8.17 MB
euler.public.guard_manual_vehicle_parking_slot_rel 1 3 delete 221 kB
euler.public.house_vote_answers_signature 1 3 delete 121 kB
euler.public.house_vote_building_rel 1 3 delete 285 kB
euler.public.journal 1 3 delete 419 MB
euler.public.long_term_events 1 3 delete 9.7 GB
euler.public.news 1 3 delete 36.1 MB
euler.public.news_ext_building_rel 1 3 delete 16.8 MB
euler.public.parking_history 1 3 delete 1.92 MB
euler.public.parking_lots 1 3 delete 371 kB
euler.public.parking_lots_buildings 1 3 delete 536 kB
euler.public.parking_rent_enterprises 1 3 delete 2.6 MB
euler.public.parking_slot_loading_zone_rel 1 3 delete 2.69 kB
euler.public.parking_slot_reservation 1 3 delete 81.7 MB
euler.public.parking_slots 1 3 delete 82.6 MB
euler.public.parking_slots_vehicles 1 3 delete 4.75 MB
euler.public.parking_zones 1 3 delete 636 kB
euler.public.parking_zones_price 1 3 delete 134 kB
euler.public.polls_buildings 1 3 delete 625 kB
euler.public.private_parking_slot_invoice 1 3 delete 65.4 kB
euler.public.properties 1 3 delete 4.82 MB
euler.public.properties_ownership_archive 1 3 delete 338 kB
euler.public.property_buildings 1 3 delete 3.35 MB
euler.public.property_external_crm_relation 1 3 delete 24.1 kB
euler.public.property_photo 1 3 delete 103 kB
euler.public.rents 1 3 delete 4.79 MB
euler.public.rooms 1 3 delete 79.5 MB
euler.public.scud_pass 1 3 delete 5.23 GB
euler.public.scud_pass_apartment_rel 1 3 delete 241 kB
euler.public.service_meters 1 3 delete 84.1 kB
euler.public.splashscreens 1 3 delete 8.7 kB
euler.public.stories_building_rel 1 3 delete 30.3 kB
euler.public.stories_complex_rel 1 3 delete 2.56 kB
euler.public.stuff_pass 1 3 delete 36 MB
euler.public.stuff_pass_car_parking 1 3 delete 14.2 MB
euler.public.ticket_external_service_building_rel 1 3 delete 43.6 kB
euler.public.ticket_type_building_rel 1 3 delete 28.4 kB
euler.public.tickets 1 3 delete 122 MB
euler.public.tri_device_object_rel 1 3 delete 27.9 kB
euler.public.tri_geo_point_object_rel 1 3 delete 7.75 kB
euler.public.user_apartment_compl 1 3 delete 1.1 GB
euler.public.user_apartment_requests 1 3 delete 14.5 MB
euler.public.userdata_buildings 1 3 delete 3.08 kB
euler.public.userdata_business 1 3 delete 10.3 MB
euler.public.userdata_parking_slots 1 3 delete 35.6 MB
euler.public.userdata_properties 1 3 delete 536 kB
euler.public.userdata_property_rel 1 3 delete 1.27 MB
euler.public.userdata_statuses_rel 1 3 delete 63.8 MB
euler.public.userdata_titles 1 3 delete 264 kB
uni_configs 1 1 compact 29.6 kB
uni_offsets 25 1 compact 2.79 kB
uni_statuses 5 1 compact 277 kB
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}