const regex = /\b([0-9]{1,2})\.[0-9]{1,2}\.[0-9]{3,4}[\.]{0,1}[0-9]{0,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([0-9]{1,2})\\.[0-9]{1,2}\\.[0-9]{3,4}[\\.]{0,1}[0-9]{0,4}', 'gm')
const str = `Microsoft SQL Server 2008 (SP1) - 10.0.2531.0 (X64) Mar 29 2009 10:11:52
Copyright (c) 1988-2008 Microsoft Corporation
Express Edition (64-bit) on Windows NT 6.1 <X64> (Build 7600: )
↓SQL Server 2016 – 13.00.900.73 (CTP3.2)
↓SQL Server 2014 12.00.2000.8 12.0.4100.1 12.0.4436.0 (SP1 CU4)
↓SQL Server 2012 11.00.2100.60 11.00.3000 11.00.5058 11.00.6020 11.0.6020 (SP3)
↓SQL Server 2008R2 10.50.1600.1 10.50.2500 10.50.4000 10.50.6000 10.50.6529 (MS15-058)
↓SQL Server 2008 10.00.1600.22 10.00.2531 10.00.4000 10.00.5500 10.00.6000 10.00.6535 (MS15-058)
↓SQL Server 2005 9.00.1399.06 9.00.2047 9.00.3042 9.00.4035 9.00.5000 9.00.5324 (MS12-070)
↓SQL Server 2000 8.00.194 8.00.384 8.00.532 8.00.760 8.00.2039 8.00.2305 (MS12-060)
↓SQL Server 7.0 7.0.623 7.0.699 7.0.842 7.00.961 7.00.1063 7.00.1152 (MS08-040)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}