package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)(.+)(\?)(.+)`)
var str = `http://www.requestly.in/replace-rule-documentation.html?type=documentation&content=html`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}