$re = '/\b1\b|(\d+)/m';
$str = '12
238
41
1
123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);