re = /hostname (?P<hostname>\w+)/
str = 'Current configuration : 1543 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ESW1
!
boot-start-marker
boot-end-marker
!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end