re = /^(?=(.*?[a-zA-Z]){3,})(?=(.*?\d){3,})(?=.*?[^a-zA-Z0-9\"])[^\"]{8,32}$/
str = 'test123_'
# Print the match result
str.match(re) do |match|
puts match.to_s
end