$re = '/(\b\w+\b)(?=.*\1)/i';
$str = 'where is mummy where is daddy';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);