const regex = /(account|acct|loan)[\S\s]*\d{10}$|\d{10}[\S\s]*(account|acct|loan)$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(account|acct|loan)[\\S\\s]*\\d{10}$|\\d{10}[\\S\\s]*(account|acct|loan)$', 'gim')
const str = `1234567890 account
account 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}