package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`°[0-5][0-9]?`)
var str = `°44
°4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}