re = /(?<!\S)[^\W\d]*\d\w*/m
str = 'happening bit mediacon #2022ppopcon wearing stell naman today #sb19official 123 because h3llo also12 or 23old'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end