import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/\\w+(?:[.:~-]\\w+)*(?:\\/\\w+(?:[.:~-]\\w+)*)*$";
final String string = "/user/update\n"
+ "/user/update-1\n"
+ "/user/update/a/b\n"
+ "/user/update~\n"
+ "/user/update::test\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}