$re = '/^0(?!\.)/m';
$str = '0
0.02
0.02
0
0
0.03';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);