$re = '/(?<!\\\\)(?:\\\\.|[^\\\\\n])*?(\\\\s)/m';
$str = 'this is a test
this is a te\\st
this is a te\\\\st
this is a te\\\\\\st
this is a te\\\\\\\\st
this is a te\\\\\\\\\\st
this is a te\\\\\\\\\\\\st';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);