#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([023]3|[067]0|[1289]1|5[5689]|67|96|88|77|65|05)$|^(8|4[358]|7[147]|51|37|30)|865|349|2.{5}5|761|74[348]|728|811|990"
Local $sString = "1386551069" & @CRLF & _
"1721125688" & @CRLF & _
"871749537" & @CRLF & _
"3410748801" & @CRLF & _
"2935589455" & @CRLF & _
"1885865030" & @CRLF & _
"776296760" & @CRLF & _
"614705581" & @CRLF & _
"3841106923" & @CRLF & _
"434616334" & @CRLF & _
"1891651756" & @CRLF & _
"1128215653" & @CRLF & _
"256582433" & @CRLF & _
"310780133" & @CRLF & _
"3971028567" & @CRLF & _
"2349690078" & @CRLF & _
"489992769" & @CRLF & _
"493183796" & @CRLF & _
"3073937100" & @CRLF & _
"3968540100" & @CRLF & _
"777207799" & @CRLF & _
"515453341" & @CRLF & _
"487926468" & @CRLF & _
"2597442171" & @CRLF & _
"950819523" & @CRLF & _
"1881247391" & @CRLF & _
"3676486536" & @CRLF & _
"3852572850" & @CRLF & _
"3498953201" & @CRLF & _
"2544525180" & @CRLF & _
"297297258" & @CRLF & _
"3783570310" & @CRLF & _
"2485456860" & @CRLF & _
"2866433205" & @CRLF & _
"2638825384" & @CRLF & _
"2405115019" & @CRLF & _
"2734986756" & @CRLF & _
"3237895121" & @CRLF & _
"1560255677" & @CRLF & _
"4228599165" & @CRLF & _
"3106247743" & @CRLF & _
"742719206" & @CRLF & _
"2409129909" & @CRLF & _
"3008020402" & @CRLF & _
"328113612" & @CRLF & _
"1081997633" & @CRLF & _
"1583987616" & @CRLF & _
"1029888552" & @CRLF & _
"1375524867" & @CRLF & _
"3913611859" & @CRLF & _
"3488464791" & @CRLF & _
"732377595" & @CRLF & _
"431649729" & @CRLF & _
"2105108903" & @CRLF & _
"1454214821" & @CRLF & _
"997975981" & @CRLF & _
"1764756211" & @CRLF & _
"2921737100" & @CRLF & _
"754705833" & @CRLF & _
"1823274447" & @CRLF & _
"450215579" & @CRLF & _
"976175934" & @CRLF & _
"1991260870" & @CRLF & _
"710069849" & @CRLF & _
"" & @CRLF & _
"28051484" & @CRLF & _
"408224582" & @CRLF & _
"1157838297" & @CRLF & _
"3470985950" & @CRLF & _
"1310525292" & @CRLF & _
"2739928315" & @CRLF & _
"3565721638" & @CRLF & _
"3568607641" & @CRLF & _
"3857889210" & @CRLF & _
"682782262" & @CRLF & _
"2845913801" & @CRLF & _
"2625196544" & @CRLF & _
"1036650602" & @CRLF & _
"3890793110" & @CRLF & _
"4276552453" & @CRLF & _
"2017874229" & @CRLF & _
"3935199786" & @CRLF & _
"1136100076" & @CRLF & _
"2406566087" & @CRLF & _
"496970764" & @CRLF & _
"2945538435" & @CRLF & _
"2830207175" & @CRLF & _
"4028712507" & @CRLF & _
"2557754740" & @CRLF & _
"572724662" & @CRLF & _
"2854602512" & @CRLF & _
"736902285" & @CRLF & _
"3612716287" & @CRLF & _
"2528051536" & @CRLF & _
"3801506272" & @CRLF & _
"164986382" & @CRLF & _
"1757334153" & @CRLF & _
"979200654" & @CRLF & _
"1377646057" & @CRLF & _
"1003603763" & @CRLF & _
"4217274922" & @CRLF & _
"3804763169" & @CRLF & _
"2502416106" & @CRLF & _
"698611315" & @CRLF & _
"3586620445" & @CRLF & _
"2343814657" & @CRLF & _
"3220493083" & @CRLF & _
"3505829324" & @CRLF & _
"4268209107" & @CRLF & _
"1798630324" & @CRLF & _
"1932820146" & @CRLF & _
"2356679271" & @CRLF & _
"1883645842" & @CRLF & _
"2495921085" & @CRLF & _
"2912113431" & @CRLF & _
"1519642783" & @CRLF & _
"924263219" & @CRLF & _
"3506109843" & @CRLF & _
"2916121049" & @CRLF & _
"4060307069" & @CRLF & _
"1470129930" & @CRLF & _
"4014068841" & @CRLF & _
"1755190161" & @CRLF & _
"311339709" & @CRLF & _
"473039620" & @CRLF & _
"2530217749" & @CRLF & _
"1297591604" & @CRLF & _
"3269125607" & @CRLF & _
"2834128510"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")